aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
commit0fdebf9347b15a6e24f2ea0afa1eeb4067bec4de (patch)
treeb82c67596a543545aa3bdd656a90c4eeb8fd7d48 /include/target.mk
parent5f6881f7e2cdffd5a12c514c6640e8f8baa7295a (diff)
downloadmaster-187ad058-0fdebf9347b15a6e24f2ea0afa1eeb4067bec4de.tar.gz
master-187ad058-0fdebf9347b15a6e24f2ea0afa1eeb4067bec4de.tar.bz2
master-187ad058-0fdebf9347b15a6e24f2ea0afa1eeb4067bec4de.zip
FPU type should not interfere with the ABI selection.
Also make sure we either do real soft-float or hard-float on ARM, with the right options. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38943 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 0f3145df59..eca218e0b3 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -232,8 +232,8 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mpcore = -march=armv6k -mtune=mpcore
CPU_CFLAGS_xscale = -march=armv5te -mtune=xscale
ifneq ($(CONFIG_SOFT_FLOAT),)
- CPU_CFLAGS_vfp = -mfpu=vfp -mfloat-abi=softfp
- CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16 -mfloat-abi=softfp
+ CPU_CFLAGS_vfp = -mfpu=vfp
+ CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
endif
endif
ifeq ($(ARCH),powerpc)