aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-23 14:55:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-23 14:55:02 +0000
commit03663e9687ea459134e39fc6f2c62ea409332893 (patch)
treebb4f1a79938715e0c7a32b2e9b0a0f45a256d489 /include/target.mk
parentb6790303ec41ff2fbe900ac887bf5322cd5f5cba (diff)
downloadmaster-187ad058-03663e9687ea459134e39fc6f2c62ea409332893.tar.gz
master-187ad058-03663e9687ea459134e39fc6f2c62ea409332893.tar.bz2
master-187ad058-03663e9687ea459134e39fc6f2c62ea409332893.zip
emit proper error messages if important kernel config files are missing
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15352 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 5484592def..a554386cd8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -119,7 +119,13 @@ LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCH
ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
LINUX_SUBCONFIG:=
endif
-LINUX_CONFCMD=$(if $(LINUX_CONFIG),$(SCRIPT_DIR)/kconfig.pl + $(GENERIC_LINUX_CONFIG) $(if $(LINUX_SUBCONFIG),+ $(LINUX_CONFIG) $(LINUX_SUBCONFIG),$(LINUX_CONFIG)),true)
+LINUX_CONFCMD=$(if $(LINUX_CONFIG), \
+ $(if $(GENERIC_LINUX_CONFIG),,$(error The generic kernel config for your kernel version is mising)) \
+ $(if $(LINUX_CONFIG),,$(error The target kernel config for your kernel version is mising)) \
+ $(SCRIPT_DIR)/kconfig.pl \
+ + $(GENERIC_LINUX_CONFIG) \
+ $(if $(LINUX_SUBCONFIG),+ $(LINUX_CONFIG) $(LINUX_SUBCONFIG),$(LINUX_CONFIG)), \
+ true)
ifeq ($(DUMP),1)
BuildTarget=$(BuildTargets/DumpCurrent)