aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-29 09:38:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-29 09:38:29 +0000
commit01695667a89785538d92a65f85c739ad27a5db09 (patch)
tree66cc67ad618d7ddfdf73f2927eeb37e20355dd44 /include/target.mk
parent6562d215fc07a8420c2dca1aa4d6e491303231bd (diff)
downloadmaster-187ad058-01695667a89785538d92a65f85c739ad27a5db09.tar.gz
master-187ad058-01695667a89785538d92a65f85c739ad27a5db09.tar.bz2
master-187ad058-01695667a89785538d92a65f85c739ad27a5db09.zip
build: unify target independent optimization options
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37600 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/include/target.mk b/include/target.mk
index eeabb25f37..b6d79fb20a 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -191,17 +191,17 @@ ifeq ($(DUMP),1)
# remove duplicates
FEATURES:=$(sort $(FEATURES))
endif
- DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -fno-caller-saves
- DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -fno-caller-saves
- DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -fno-caller-saves
- DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -mno-branch-likely
+ DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486
+ DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64
+ DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e
+ DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -mno-branch-likely
DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
- DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -fno-caller-saves
+ DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64
DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
- DEFAULT_CFLAGS_sparc=-Os -pipe -mcpu=ultrasparc -fno-caller-saves
- DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
+ DEFAULT_CFLAGS_sparc=-Os -pipe -mcpu=ultrasparc
+ DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale
DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
- DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -fno-caller-saves)
+ DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe)
endif
define BuildTargets/DumpCurrent