aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-08 17:15:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-08 17:15:45 +0000
commitfdd463c5910aedc83ead46fffe7356b7a4a0ebbe (patch)
tree216c4782bcbcbea4c2c63cb2a5a46f25f2ed1b78 /include/subdir.mk
parent139131df376bef6c57cfffc99a4514afb19e13ec (diff)
downloadmaster-187ad058-fdd463c5910aedc83ead46fffe7356b7a4a0ebbe.tar.gz
master-187ad058-fdd463c5910aedc83ead46fffe7356b7a4a0ebbe.tar.bz2
master-187ad058-fdd463c5910aedc83ead46fffe7356b7a4a0ebbe.zip
tools: fix stampfile dependency handling when the list of build dirs changes (#15186)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39845 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index a2adff2a59..a08c94247e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -57,7 +57,7 @@ endef
ifndef DUMP_TARGET_DB
# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
define stampfile
- $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+ $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(5)
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $(if $(QUIET),--no-print-directory) $$($(1)/flags-$(3)) $(1)/$(3)