aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:16 +0000
commitf522e7f64f568917b37dfac6ba13fca4d718aa94 (patch)
tree1cd320cf1442ba16535697123c06b3cc69121ac1 /include/subdir.mk
parentb5fac0256a30aa417ed90e02afc2d600b367c775 (diff)
downloadmaster-187ad058-f522e7f64f568917b37dfac6ba13fca4d718aa94.tar.gz
master-187ad058-f522e7f64f568917b37dfac6ba13fca4d718aa94.tar.bz2
master-187ad058-f522e7f64f568917b37dfac6ba13fca4d718aa94.zip
add support for config options checking in top-level directory stampfiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15112 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 40e31923bc..d4076e6c47 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -46,9 +46,9 @@ define subdir
$(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
endef
-# Parameters: <subdir> <name> <target> <depends>
+# Parameters: <subdir> <name> <target> <depends> <config options>
define stampfile
- $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
+ $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)