aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 03:01:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 03:01:10 +0000
commitbb84df1c5ef78424c118ad98530c3d2af02c9e4e (patch)
tree09a046030484ea5e7213d665c9edb41ce8b37f1f /include/subdir.mk
parentc295c38efce72dc02f9c0d71a9cfc409ace8e6d8 (diff)
downloadmaster-187ad058-bb84df1c5ef78424c118ad98530c3d2af02c9e4e.tar.gz
master-187ad058-bb84df1c5ef78424c118ad98530c3d2af02c9e4e.tar.bz2
master-187ad058-bb84df1c5ef78424c118ad98530c3d2af02c9e4e.zip
allow target specific builddir list override
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8204 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 046a6adf6f..79624238b5 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -39,7 +39,7 @@ define subdir
)
)
$(foreach target,$(SUBTARGETS),
- $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$($(1)/builddirs),$(1)/$(bd)/$(target)))
+ $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$(if $($(1)/builddirs-$(target)),$($(1)/builddirs-$(target)),$($(1)/builddirs)),$(1)/$(bd)/$(target)))
)
endef