aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2009-05-28 16:30:04 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2009-05-28 16:30:04 +0000
commit92dfe3875a17cf226981ac6ac641dd6a4fe246db (patch)
tree1f0359fb95cb6b91dae7deedf0573ae3a81cc55c /include/subdir.mk
parent8b02ac2366c93c87dc57c0730191bc48223897e7 (diff)
downloadmaster-187ad058-92dfe3875a17cf226981ac6ac641dd6a4fe246db.tar.gz
master-187ad058-92dfe3875a17cf226981ac6ac641dd6a4fe246db.tar.bz2
master-187ad058-92dfe3875a17cf226981ac6ac641dd6a4fe246db.zip
added BUILD_LOG_DIR variable, make clean will delete the ./logs dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16148 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 26a8626524..be8c308205 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -34,8 +34,8 @@ define subdir
$(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(btype)/$(target): $(1)/$(bd)/$(btype)/$(target)))
)
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
- $(if $(BUILD_LOG),@mkdir -p $(TOPDIR)/logs/$(1)/$(bd))
- +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(TOPDIR)/logs/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
+ $(if $(BUILD_LOG),@mkdir -p $(BUILD_LOG_DIR)/$(1)/$(bd))
+ +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
# legacy targets