aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-07-11 12:48:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-07-11 12:48:59 +0000
commit7c2dcfc1b33db2d5ddd538cba271e15b64efc0be (patch)
tree5b7ff86cc5ecc551dd421147dc6f8ddbb5b1b5ea /include/subdir.mk
parentb0a32ca0c9450e47fa72881ddd03d2198c3c0ff2 (diff)
downloadmaster-187ad058-7c2dcfc1b33db2d5ddd538cba271e15b64efc0be.tar.gz
master-187ad058-7c2dcfc1b33db2d5ddd538cba271e15b64efc0be.tar.bz2
master-187ad058-7c2dcfc1b33db2d5ddd538cba271e15b64efc0be.zip
move the toolchain_install stampfile to the right place to fix spurious missing toolchain errors after cleaning stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16776 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index d93d40fca7..3c1e3f9cae 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -47,9 +47,9 @@ define subdir
$(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
endef
-# Parameters: <subdir> <name> <target> <depends> <config options>
+# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
define stampfile
- $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+ $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)