aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 21:30:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 21:30:18 +0000
commit58896959fd358d704cba341f9722cda7e2fc3e12 (patch)
treef3a935443756101282efca1f3a7fc063823d9386 /include/subdir.mk
parent8186b8e98eb24ca94f09fd29d3c9dc05597a37a8 (diff)
downloadmaster-187ad058-58896959fd358d704cba341f9722cda7e2fc3e12.tar.gz
master-187ad058-58896959fd358d704cba341f9722cda7e2fc3e12.tar.bz2
master-187ad058-58896959fd358d704cba341f9722cda7e2fc3e12.zip
ignore dependencies when using QUILT
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8244 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 4348c7b93d..e985c30ff0 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -23,7 +23,7 @@ define subdir
$(foreach bd,$($(1)/builddirs),
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
- $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
+ $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+$$(MAKE) -j1 -C $(1)/$(bd) $(target)
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))