aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-30 22:43:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-30 22:43:25 +0000
commit485f2e16f4da17126fb20deb11fdd71535f97f23 (patch)
treedc3ea2057f8d7654bb4b789aaaeba53cb9463f71 /include/subdir.mk
parent6826d08dbd54196c2e762051bbc49c9d27a25343 (diff)
downloadmaster-187ad058-485f2e16f4da17126fb20deb11fdd71535f97f23.tar.gz
master-187ad058-485f2e16f4da17126fb20deb11fdd71535f97f23.tar.bz2
master-187ad058-485f2e16f4da17126fb20deb11fdd71535f97f23.zip
fix a dependency bug
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8561 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 0a3eff307e..40a06ed9e1 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -38,7 +38,7 @@ endef
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build
- @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))