aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
commit353386a64396d68ea611e40dc746cbf691e7e9ce (patch)
tree551d39ed952b9f21489103c31c067b4af6f8a22d /include/subdir.mk
parent789fbe9b09a0accb0e416be0ece64454df3a3ae0 (diff)
downloadmaster-187ad058-353386a64396d68ea611e40dc746cbf691e7e9ce.tar.gz
master-187ad058-353386a64396d68ea611e40dc746cbf691e7e9ce.tar.bz2
master-187ad058-353386a64396d68ea611e40dc746cbf691e7e9ce.zip
move host build in packages into a separate namespace: package/<name>/host/<target>
this allows dependencies between host and target packages, and saves unnecessary host builds for packages that contain both variants git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 3bf1a4bb79..e6c8066187 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -27,6 +27,11 @@ define subdir
$(foreach bd,$($(1)/builddirs),
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
+ $(foreach btype,$(buildtypes-$(bd)),
+ $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(btype)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(btype)/$(target)) $(call $(1)//$(btype)/$(target),$(1)/$(bd)/$(btype))))
+ +$$(SUBMAKE) -C $(1)/$(bd) $(btype)-$(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(btype)-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) [$(btype)] failed to build.))
+ $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(btype)/$(target))
+ )
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+$$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))