aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-18 21:53:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-18 21:53:35 +0000
commit06452459df6022ed1f3c274d07e6493fc785f5a2 (patch)
treeda393ee5906df1b1f66fb5b229fa1a9814218988 /include/subdir.mk
parente51f5ff0269821e1ab8739c02f7868de1a3596e7 (diff)
downloadmaster-187ad058-06452459df6022ed1f3c274d07e6493fc785f5a2.tar.gz
master-187ad058-06452459df6022ed1f3c274d07e6493fc785f5a2.tar.bz2
master-187ad058-06452459df6022ed1f3c274d07e6493fc785f5a2.zip
add makefile target alias package/<name>/host/<target> for host builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index e6c8066187..40e31923bc 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -31,6 +31,7 @@ define subdir
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(btype)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(btype)/$(target)) $(call $(1)//$(btype)/$(target),$(1)/$(bd)/$(btype))))
+$$(SUBMAKE) -C $(1)/$(bd) $(btype)-$(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(btype)-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) [$(btype)] failed to build.))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(btype)/$(target))
+ $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(btype)/$(target): $(1)/$(bd)/$(btype)/$(target)))
)
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+$$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))