aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-16 06:35:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-16 06:35:00 +0000
commitd3daf2103ece8f4da8e9c2e891e4b736cca2b132 (patch)
tree9fcee440137be8973ef0aa96dcd4cfc4afd36b5d /include/scan.mk
parent93e3dd8d3fa96f2de0509f9d1aeea0015fe21237 (diff)
downloadmaster-187ad058-d3daf2103ece8f4da8e9c2e891e4b736cca2b132.tar.gz
master-187ad058-d3daf2103ece8f4da8e9c2e891e4b736cca2b132.tar.bz2
master-187ad058-d3daf2103ece8f4da8e9c2e891e4b736cca2b132.zip
find: use -follow instead of -L, some systems don't support -L
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8000 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index a0ee1ad678..04add4016c 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -31,7 +31,7 @@ endef
$(FILELIST):
rm -f tmp/info/.files-$(SCAN_TARGET)-*
- find -L $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
+ find -follow $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
tmp/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \