aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-22 09:35:40 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-22 09:35:40 +0000
commit7fdb8680e3e1c3f7f415e20186f0bcf0799fd801 (patch)
treefe04e7ef788200bc3981b7aa34e504bd5742e216 /include/scan.mk
parentf1328aff8efbbf37a6bace89a6728c2f2c9beee2 (diff)
downloadmaster-187ad058-7fdb8680e3e1c3f7f415e20186f0bcf0799fd801.tar.gz
master-187ad058-7fdb8680e3e1c3f7f415e20186f0bcf0799fd801.tar.bz2
master-187ad058-7fdb8680e3e1c3f7f415e20186f0bcf0799fd801.zip
build: allow openwrt.git packages to be replaced by feeds
Currently, replacing a package available in openwrt.git requires modifications in openwrt.git, or requires duplicating the package in a feed but with a different name, which causes all kind of problems related to dependencies (all packages selecting it would have to be modified accordingly to select the new package). With this change, if a package with the same name is present both in feeds/ and package/ folders, the one in feeds/ can override the one in package/, both in the menuconfig and during the build, by passing the "-f" option to "./scripts/feeds install" This mechanism is particularly useful for vendor tree, or in general for application which needs to replace one particular package which exists within openwrt.git by a custom/newer version. Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44076 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 0998333439..138707db08 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -43,7 +43,7 @@ endef
$(FILELIST):
rm -f $(TMP_DIR)/info/.files-$(SCAN_TARGET)-*
- $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|Build(Package|Target)|.+Package)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
+ $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|Build(Package|Target)|.+Package)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -f include/scan.awk > $@
$(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \