aboutsummaryrefslogtreecommitdiffstats
path: root/include/scan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-15 23:38:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-15 23:38:09 +0000
commit4d93ce80080bfa8258b43db04e2b82d129604130 (patch)
treec2590df24de6070f3d07aebf4709eebf00de411f /include/scan.mk
parent4463126a210b59e0b414243b6090cdbb5de3eaa0 (diff)
downloadmaster-187ad058-4d93ce80080bfa8258b43db04e2b82d129604130.tar.gz
master-187ad058-4d93ce80080bfa8258b43db04e2b82d129604130.tar.bz2
master-187ad058-4d93ce80080bfa8258b43db04e2b82d129604130.zip
follow symlinks in package scan
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7984 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/scan.mk')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 9bd0f379da..a0ee1ad678 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -31,7 +31,7 @@ endef
$(FILELIST):
rm -f tmp/info/.files-$(SCAN_TARGET)-*
- find $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
+ find -L $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
tmp/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \