aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-16 01:56:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-16 01:56:04 +0000
commitf46b6a019569e69dfb8a7060e7f36d01e5eedd03 (patch)
tree7a8919b2830b1c51b5dfe7742261a08168b118a2 /include/quilt.mk
parent97ca42e813d5a0a03bd1a70576375dad8469044a (diff)
downloadmaster-187ad058-f46b6a019569e69dfb8a7060e7f36d01e5eedd03.tar.gz
master-187ad058-f46b6a019569e69dfb8a7060e7f36d01e5eedd03.tar.bz2
master-187ad058-f46b6a019569e69dfb8a7060e7f36d01e5eedd03.zip
prepare for the transition to linux 2.6.22 - make it possible to override the kernel version in the target makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7644 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 395f64e174..e02fab0879 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -46,11 +46,11 @@ endif
define Kernel/Patch/Default
if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
- $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PLATFORM_DIR)/patches,generic/), \
- if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
+ $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PATCH_DIR),generic/), \
+ if [ -d $(GENERIC_PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PATCH_DIR); fi \
)
- $(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
- if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi \
+ $(if $(strip $(QUILT)),$(call Quilt/Patch,$(PATCH_DIR),platform/), \
+ if [ -d $(PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(PATCH_DIR); fi \
)
$(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
@@ -79,8 +79,8 @@ define Quilt/Refresh/Kernel
echo "All kernel patches must start with either generic/ or platform/"; \
false; \
}
- $(call Quilt/RefreshDir,$(GENERIC_PLATFORM_DIR)/patches,generic/)
- $(call Quilt/RefreshDir,./patches,platform/)
+ $(call Quilt/RefreshDir,$(GENERIC_PATCH_DIR),generic/)
+ $(call Quilt/RefreshDir,$(PATCH_DIR),platform/)
endef
quilt-check: $(STAMP_PREPARED) FORCE