aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-29 00:25:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-29 00:25:38 +0000
commitccff8348deb578ad232ea0c7fc6ae92e8d22f2de (patch)
tree823247932d4869fafb54c8dda37fe288f028be5a /include/quilt.mk
parentc1e4663769332bbf1a0a6907e5fb4b559421209e (diff)
downloadmaster-187ad058-ccff8348deb578ad232ea0c7fc6ae92e8d22f2de.tar.gz
master-187ad058-ccff8348deb578ad232ea0c7fc6ae92e8d22f2de.tar.bz2
master-187ad058-ccff8348deb578ad232ea0c7fc6ae92e8d22f2de.zip
proper series file support for regular packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9059 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 4dce2a6d8c..c156d3062d 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -44,7 +44,12 @@ ifneq ($(QUILT),)
else
define Build/Patch/Default
@if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
- $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ if [ -f $(PATCH_DIR)/series ]; then \
+ grep -vE '^#' $(PATCH_DIR)/series | xargs -n1 \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ else \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ fi; \
fi
endef
endif