aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
commitaf835ce5169cc7829928e8e224508526b9ef2870 (patch)
tree093db669aa3ce1faaf10c4575bb61d502918bedc /include/quilt.mk
parentdabd596e39c58eddc0f2361d12f415d5482307aa (diff)
downloadmaster-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.tar.gz
master-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.tar.bz2
master-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.zip
change the way ./files* and the generic kernel files are applied. ./files now applies to *ALL* kernel versions, and is copied along with ./files-* - this gets rid of quite a bit of redundancy in the extra kernel drivers.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 70bc84e4cc..c569231173 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -68,11 +68,8 @@ endef
define Kernel/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
- if [ -d $(GENERIC_FILES_DIR) ]; then $(CP) $(GENERIC_FILES_DIR)/* $(LINUX_DIR)/; fi
- if [ -d $(FILES_DIR) ]; then \
- $(CP) $(FILES_DIR)/* $(LINUX_DIR)/; \
- find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
- fi
+ $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+ find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
$(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
$(call PatchDir,$(PATCH_DIR),platform/)
endef