aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 23:54:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 23:54:17 +0000
commit835b12f4adb7a71243c8b7c7c3f844710953320d (patch)
tree9f4b7ed0e65e41d38e871fe7417a8ff58fc68ab8 /include/quilt.mk
parenteaf40953270e790fe3ba4b7bc8dd19c308efed90 (diff)
downloadmaster-187ad058-835b12f4adb7a71243c8b7c7c3f844710953320d.tar.gz
master-187ad058-835b12f4adb7a71243c8b7c7c3f844710953320d.tar.bz2
master-187ad058-835b12f4adb7a71243c8b7c7c3f844710953320d.zip
allow a separate patch directory for host patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14630 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 77b76a6dae..71fee06f14 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -13,6 +13,8 @@ ifeq ($(TARGET_BUILD),1)
endif
PATCH_DIR?=./patches
FILES_DIR?=./files
+HOST_PATCH_DIR?=$(PATCH_DIR)
+HOST_FILES_DIR?=$(FILES_DIR)
ifeq ($(MAKECMDGOALS),refresh)
override QUILT=1
@@ -78,7 +80,7 @@ endif
define Host/Patch/Default
$(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
- $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+ $(call PatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
$(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
endef