aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-04 15:32:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-04 15:32:55 +0000
commit64722c42b561a7c99626248aa812535e5c907e3c (patch)
treec5d23bd58fbd42e0a7a7a5b94e00b7039a292738 /include/quilt.mk
parentc3ca0a7ad90e2365d7b66511297095a6b858d565 (diff)
downloadmaster-187ad058-64722c42b561a7c99626248aa812535e5c907e3c.tar.gz
master-187ad058-64722c42b561a7c99626248aa812535e5c907e3c.tar.bz2
master-187ad058-64722c42b561a7c99626248aa812535e5c907e3c.zip
separate series file fixup from quilt check to avoid series file breakages after fixing a broken patch stack with quilt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9120 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 667653f320..daeef9431f 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -54,10 +54,11 @@ endef
QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
ifneq ($(QUILT),)
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
+ STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
override CONFIG_AUTOREBUILD=
- $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
+ $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
prepare: $(STAMP_PATCHED)
- quilt-check: $(STAMP_PATCHED)
+ quilt-check: $(STAMP_CHECKED)
endif
define Build/Patch/Default
@@ -119,6 +120,9 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
find * -type f \! -name series | sort > series; \
fi; \
)
+ touch $@
+
+$(STAMP_CHECKED): $(STAMP_PATCHED)
if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
touch $@