aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
commit499485004b52b5960c950922fb1dedcedd0923fa (patch)
tree78a221d6379016a74f33e2257e609a7194db7f27 /include/quilt.mk
parentd2c8e2185055230a43bafaa28017dc11ee40d927 (diff)
downloadmaster-187ad058-499485004b52b5960c950922fb1dedcedd0923fa.tar.gz
master-187ad058-499485004b52b5960c950922fb1dedcedd0923fa.tar.bz2
master-187ad058-499485004b52b5960c950922fb1dedcedd0923fa.zip
some minor fixes, cleanups, package build abstraction
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index a7aac91c06..4dce2a6d8c 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -5,6 +5,9 @@
# See /LICENSE for more information.
#
+ifneq ($(__quilt_inc),1)
+__quilt_inc:=1
+
ifeq ($(TARGET_BUILD),1)
PKG_BUILD_DIR:=$(LINUX_DIR)
endif
@@ -134,3 +137,4 @@ refresh: quilt-check
update: quilt-check
$(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+endif