aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
commit353386a64396d68ea611e40dc746cbf691e7e9ce (patch)
tree551d39ed952b9f21489103c31c067b4af6f8a22d /include/quilt.mk
parent789fbe9b09a0accb0e416be0ece64454df3a3ae0 (diff)
downloadmaster-187ad058-353386a64396d68ea611e40dc746cbf691e7e9ce.tar.gz
master-187ad058-353386a64396d68ea611e40dc746cbf691e7e9ce.tar.bz2
master-187ad058-353386a64396d68ea611e40dc746cbf691e7e9ce.zip
move host build in packages into a separate namespace: package/<name>/host/<target>
this allows dependencies between host and target packages, and saves unnecessary host builds for packages that contain both variants git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 0d63e62fd2..fbb3e01e35 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -67,7 +67,7 @@ ifneq ($(PKG_BUILD_DIR),)
endif
ifneq ($(HOST_BUILD_DIR),)
- HOST_QUILT?=$(if $(wildcard $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used),y)
+ HOST_QUILT?=$(if $(findstring command,$(origin $(QUILT))),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
ifneq ($(HOST_QUILT),)
HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked