aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 17:50:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 17:50:31 +0000
commit1ca982f27c5068144dd637d761637da441cd0069 (patch)
tree525e26bb0d89138cf283238aecd5e8b86b42f868 /include/quilt.mk
parent78e17a6b4f43735095a439fcf18702ebabbd9e84 (diff)
downloadmaster-187ad058-1ca982f27c5068144dd637d761637da441cd0069.tar.gz
master-187ad058-1ca982f27c5068144dd637d761637da441cd0069.tar.bz2
master-187ad058-1ca982f27c5068144dd637d761637da441cd0069.zip
eliminate redundancy by creating the quilt_used stampfile in the right place
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14620 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 4323c77b2b..77b76a6dae 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -79,11 +79,13 @@ endif
define Host/Patch/Default
$(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
$(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+ $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
endef
define Build/Patch/Default
$(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
$(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+ $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)