aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 03:21:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 03:21:52 +0000
commit0a5976b604f9cc8c81dfdbc7dc4ecb068345c3b9 (patch)
tree53bead96f9d9fbb1b69984e0825e658fbb86c4a0 /include/quilt.mk
parent2f5a8c4214e03ee0bb0447e693f7ef67d42a52de (diff)
downloadmaster-187ad058-0a5976b604f9cc8c81dfdbc7dc4ecb068345c3b9.tar.gz
master-187ad058-0a5976b604f9cc8c81dfdbc7dc4ecb068345c3b9.tar.bz2
master-187ad058-0a5976b604f9cc8c81dfdbc7dc4ecb068345c3b9.zip
fix quilt variable and stampfile usage for host builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14910 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index fbb3e01e35..32a62fb0df 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -55,6 +55,10 @@ define PatchDir
$(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
endef
+define HostPatchDir
+$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
+
ifneq ($(PKG_BUILD_DIR),)
QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
ifneq ($(QUILT),)
@@ -78,9 +82,9 @@ ifneq ($(HOST_BUILD_DIR),)
endif
define Host/Patch/Default
- $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
- $(call PatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
- $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
+ $(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+ $(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+ $(if $(HOST_QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
endef
define Build/Patch/Default