aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-12 11:53:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-12 11:53:23 +0000
commit95b120dbaa32346dc15c4ef387009727200b8d9b (patch)
tree254b46de5f535f478b1e52c08c5c9dc33da48908 /include/prereq.mk
parente35e421a546deefeb1414ce1a44535e7240ba136 (diff)
downloadmaster-187ad058-95b120dbaa32346dc15c4ef387009727200b8d9b.tar.gz
master-187ad058-95b120dbaa32346dc15c4ef387009727200b8d9b.tar.bz2
master-187ad058-95b120dbaa32346dc15c4ef387009727200b8d9b.zip
Add a requireheader for squid, should fix it (#2205)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8404 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 660f67cb1b..8e5490ccff 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -47,4 +47,12 @@ define RequireCommand
$$(eval $$(call Require,$(1),$(2)))
endef
+define RequireHeader
+ define Require/$(1)
+ [ -e "$(1)" ]
+ endef
+
+ $$(eval $$(call Require,$(1),$(2)))
+endef
+
.NOTPARALLEL: