aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-16 12:38:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-16 12:38:16 +0000
commit36787ed17636454353ba1ea87863afb963960d54 (patch)
tree86addd19c3ab5be7186f57e1065b132d78637cf6 /include/prereq.mk
parent6b2fc8f07ddc50965b4188967d9cb8d2b5a389c8 (diff)
downloadmaster-187ad058-36787ed17636454353ba1ea87863afb963960d54.tar.gz
master-187ad058-36787ed17636454353ba1ea87863afb963960d54.tar.bz2
master-187ad058-36787ed17636454353ba1ea87863afb963960d54.zip
build: do not overwrite already existing host commands
This prevents a later prereq check from overwriting the installed tar binary. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46982 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 33ac278232..6cb590e360 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -86,6 +86,7 @@ endef
# 3+: candidates
define SetupHostCommand
define Require/$(1)
+ [ -f "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0; \
for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
$(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
$(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \