aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-04-24 19:28:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-04-24 19:28:11 +0000
commited2d5abe9ee8192b898751f88e4cc38aa9a9030e (patch)
tree1b2f204d958a0de527a968f0dd4201640909a184 /include/prereq-build.mk
parentc4d4aef2292553295bd5d48dd63446369205ebe1 (diff)
downloadmaster-187ad058-ed2d5abe9ee8192b898751f88e4cc38aa9a9030e.tar.gz
master-187ad058-ed2d5abe9ee8192b898751f88e4cc38aa9a9030e.tar.bz2
master-187ad058-ed2d5abe9ee8192b898751f88e4cc38aa9a9030e.zip
build: add a prereq check for file (#15692)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40568 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index b7ada69bb4..2e8d712cb8 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -187,3 +187,7 @@ endef
$(eval $(call Require,getopt-extended, \
Please install an extended getopt version that supports --long \
))
+
+$(eval $(call RequireCommand,file, \
+ Please install file. \
+))