aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-14 14:25:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-14 14:25:29 +0000
commite97eede58b00a64e305c1e6c111752d12a07aaba (patch)
treeb2dfc9bc0a2d3a027dba15108f3d793202a281cb /include/prereq-build.mk
parentf7bde0d88e31195d81383437373a3387af3abcbf (diff)
downloadmaster-187ad058-e97eede58b00a64e305c1e6c111752d12a07aaba.tar.gz
master-187ad058-e97eede58b00a64e305c1e6c111752d12a07aaba.tar.bz2
master-187ad058-e97eede58b00a64e305c1e6c111752d12a07aaba.zip
[include] add a prereq check for umask 0022, other settings will result in broken packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23442 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 84d3f2274c..afb92ff021 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -18,6 +18,13 @@ $(eval $(call Require,non-root, \
Please do not compile as root. \
))
+define Require/umask-0022
+ [ "$$(shell umask)" -eq 22 ]
+endef
+$(eval $(call Require,umask-0022, \
+ Please compile with umask 0022. \
+))
+
# Required for the toolchain
define Require/working-make
$(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null