aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-02-07 10:07:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-02-07 10:07:31 +0000
commitd09ab54291924a1ff4b904588fe81aefa34b1581 (patch)
tree14ae4146453e26c41ddd34072aa2b5a6d9170c31 /include/prereq-build.mk
parent435c83154e3424223d2dcdaffe36680f38d44ebf (diff)
downloadmaster-187ad058-d09ab54291924a1ff4b904588fe81aefa34b1581.tar.gz
master-187ad058-d09ab54291924a1ff4b904588fe81aefa34b1581.tar.bz2
master-187ad058-d09ab54291924a1ff4b904588fe81aefa34b1581.zip
build: accept apple llvm as fallback for gcc/g++
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44298 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 926a06f8ba..3f8f9870b3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -31,7 +31,8 @@ $(eval $(call SetupHostCommand,gcc, \
gcc49 --version | grep gcc, \
gcc48 --version | grep gcc, \
gcc47 --version | grep gcc, \
- gcc46 --version | grep gcc))
+ gcc46 --version | grep gcc, \
+ gcc --version | grep Apple.LLVM ))
$(eval $(call TestHostCommand,working-gcc, \
Please reinstall the GNU C Compiler - it appears to be broken, \
@@ -45,7 +46,8 @@ $(eval $(call SetupHostCommand,g++, \
g++49 --version | grep g++, \
g++48 --version | grep g++, \
g++47 --version | grep g++, \
- g++46 --version | grep g++))
+ g++46 --version | grep g++, \
+ g++ --version | grep Apple.LLVM ))
$(eval $(call TestHostCommand,working-g++, \
Please reinstall the GNU C++ Compiler - it appears to be broken, \