aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-05 14:11:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-05 14:11:25 +0000
commitb78ab35ab4ed20223b8944a47e7106b6e8442ff9 (patch)
treef26dfc1b497bab630790c0f091f558dc61c806bb /include/prereq-build.mk
parent592bda01ac55aab778c18c1d9bfc7d734dbd6151 (diff)
downloadmaster-187ad058-b78ab35ab4ed20223b8944a47e7106b6e8442ff9.tar.gz
master-187ad058-b78ab35ab4ed20223b8944a47e7106b6e8442ff9.tar.bz2
master-187ad058-b78ab35ab4ed20223b8944a47e7106b6e8442ff9.zip
build: use host cflags/ldflags for openssl prereq check
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6f491375c6..77fa991b04 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -74,7 +74,7 @@ $(eval $(call TestHostCommand,zlib, \
$(eval $(call TestHostCommand,libssl, \
Please install the openssl library (with development headers), \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
- gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+ gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \