aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-20 09:23:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-20 09:23:55 +0000
commita9160b7360f2624e43b99f3cc25f11b82bd2fc09 (patch)
treecf45e228cee6ab43cdeda5b819e5c0e240f72233 /include/prereq-build.mk
parent6c36b1d9d087d7674c1ac71ebc982e1128d8fda4 (diff)
downloadmaster-187ad058-a9160b7360f2624e43b99f3cc25f11b82bd2fc09.tar.gz
master-187ad058-a9160b7360f2624e43b99f3cc25f11b82bd2fc09.tar.bz2
master-187ad058-a9160b7360f2624e43b99f3cc25f11b82bd2fc09.zip
prereq-build: rename the openssl check to libssl, add back the old check - it is required after all
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42999 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 4a87c9211a..5a743225f6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,13 +168,17 @@ $(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))
-define Require/openssl
+define Require/libssl
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
endef
-$(eval $(call Require,openssl, \
- Please install openssl (with development headers) \
+$(eval $(call Require,libssl, \
+ Please install the openssl library (with development headers) \
+))
+
+$(eval $(call RequireCommand,openssl, \
+ Please install openssl. \
))
define Require/gnu-find