aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 21:06:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 21:06:45 +0000
commit8a1b6b309826836d504effc98f554d8bc0988b60 (patch)
treeaff9fc1ec79abef6e7b1da340aadb99c6e19c285 /include/prereq-build.mk
parent11a1b240a0478c89270eac4568205cbcd037215e (diff)
downloadmaster-187ad058-8a1b6b309826836d504effc98f554d8bc0988b60.tar.gz
master-187ad058-8a1b6b309826836d504effc98f554d8bc0988b60.tar.bz2
master-187ad058-8a1b6b309826836d504effc98f554d8bc0988b60.zip
more portability fixes and a prereq check for gnu tar
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5037 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index a2e5469fa6..d6396af8e2 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -8,6 +8,7 @@
include $(TOPDIR)/rules.mk
TMP_DIR:=$(TOPDIR)/tmp
include $(INCLUDE_DIR)/prereq.mk
+include $(INCLUDE_DIR)/host.mk
define Require/non-root
[ "$$(shell whoami)" != "root" ]
@@ -94,3 +95,11 @@ $(eval $(call RequireCommand,patch, \
$(eval $(call RequireCommand,perl, \
Please install perl. \
))
+
+define Require/gnutar
+ $(TAR) --version 2>&1 | grep GNU > /dev/null
+endef
+
+$(eval $(call Require,gnutar, \
+ Please install GNU tar. \
+))