aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:00:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:00:47 +0000
commit875eefa24cea3fbe408fa1bd3e8bf1fce8b9bc08 (patch)
tree784b4190bba97f7d39ef15d82d80500c0df638cc /include/prereq-build.mk
parent57364b8623fd989fa50c50b22260af25c9eaceae (diff)
downloadmaster-187ad058-875eefa24cea3fbe408fa1bd3e8bf1fce8b9bc08.tar.gz
master-187ad058-875eefa24cea3fbe408fa1bd3e8bf1fce8b9bc08.tar.bz2
master-187ad058-875eefa24cea3fbe408fa1bd3e8bf1fce8b9bc08.zip
include: remove static tool linking support
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44286 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 306a6b3e38..1c8de0638e 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -68,24 +68,6 @@ $(eval $(call TestHostCommand,libssl, \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
-ifneq ($(HOST_STATIC_LINKING),)
- $(eval $(call TestHostCommand,working-gcc-static, \
- Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL)., \
- echo 'int main(int argc, char **argv) { return 0; }' | \
- gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -))
-
- $(eval $(call TestHostCommand,working-g++-static, \
- Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL)., \
- echo 'int main(int argc, char **argv) { return 0; }' | \
- g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
- $(TMP_DIR)/a.out))
-
- $(eval $(call TestHostCommand,zlib-static, \
- Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL)., \
- echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
- gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz))
-endif
-
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
gtar --version 2>&1 | grep GNU, \