aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 23:35:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 23:35:20 +0000
commit727a3dd0fabbe928d0a32f365784c04f1ff48e50 (patch)
treefb43ace96430ed81dcc7477c03c26f03a1d03515 /include/prereq-build.mk
parent06d0aa1fb64fb56c8af5ca08e7c49fe8430202d2 (diff)
downloadmaster-187ad058-727a3dd0fabbe928d0a32f365784c04f1ff48e50.tar.gz
master-187ad058-727a3dd0fabbe928d0a32f365784c04f1ff48e50.tar.bz2
master-187ad058-727a3dd0fabbe928d0a32f365784c04f1ff48e50.zip
[include] add a build preeq check for glibc-static
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33121 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 228fcdcb0b..28c2a216b2 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -70,6 +70,15 @@ $(eval $(call Require,working-g++, \
Please install the GNU C++ Compiler (g++). \
))
+define Require/working-gcc-static
+ echo 'int main(int argc, char **argv) { return 0; }' | \
+ gcc -x c -static -o $(TMP_DIR)/a.out -
+endef
+
+$(eval $(call Require,working-gcc-static, \
+ Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
+))
+
define Require/ncurses
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses