aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 17:38:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 17:38:54 +0000
commit65180dee3dbb44f0b38621cb8ac6d302efd39f67 (patch)
tree8859995132fa6dd740f784c1c2e1ac940c53e345 /include/prereq-build.mk
parenta7693a268f662fd2b96c662d4e84c6cf59aa202b (diff)
downloadmaster-187ad058-65180dee3dbb44f0b38621cb8ac6d302efd39f67.tar.gz
master-187ad058-65180dee3dbb44f0b38621cb8ac6d302efd39f67.tar.bz2
master-187ad058-65180dee3dbb44f0b38621cb8ac6d302efd39f67.zip
include: fix prereq tests for perl and file (#18911)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44296 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7945f05325..926a06f8ba 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -132,7 +132,7 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
wget --version | grep GNU))
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
- perl --version | grep "perl 5"))
+ perl --version | grep "perl.*v5"))
$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
python2.7 -V 2>&1 | grep Python, \
@@ -146,7 +146,7 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
git clone 2>&1 | grep -- --recursive))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
- file --version | grep file))
+ file --version 2>&1 | grep file))
$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
openssl version | grep OpenSSL))