aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-11 22:28:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-11 22:28:10 +0000
commit6510d71bc76e05f5098219c9238e1fda6e64ec44 (patch)
treeb8bf17cb7e60013255b1a07147bf72b49a9d8018 /include/prereq-build.mk
parent7e6956ad88d17f90f2550ab61abdbe4a6c6466d6 (diff)
downloadmaster-187ad058-6510d71bc76e05f5098219c9238e1fda6e64ec44.tar.gz
master-187ad058-6510d71bc76e05f5098219c9238e1fda6e64ec44.tar.bz2
master-187ad058-6510d71bc76e05f5098219c9238e1fda6e64ec44.zip
add prereq check for gnu find
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9710 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 11ee111ced..b0114f0b9e 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -123,3 +123,10 @@ $(eval $(call RequireCommand,autoconf, \
Please install GNU autoconf. \
))
+define Require/gnu-find
+ $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+ Please install GNU find \
+))