aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-25 19:00:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-25 19:00:43 +0000
commit62a6e10227efed2cfa1200710441768d2017a713 (patch)
treebcb3537a760541268e889c03e623689a1171f782 /include/prereq-build.mk
parent61af435bbc3e061ae1716f53428449201a3c563e (diff)
downloadmaster-187ad058-62a6e10227efed2cfa1200710441768d2017a713.tar.gz
master-187ad058-62a6e10227efed2cfa1200710441768d2017a713.tar.bz2
master-187ad058-62a6e10227efed2cfa1200710441768d2017a713.zip
improve support for building on mac os x by improving detection of missing components
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14180 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index d6d2d73a63..f0e1da9810 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
OpenWrt can only be built on a case-sensitive filesystem \
))
+define Require/getopt
+ getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+ Please install GNU getopt \
+))
+
+define Require/fileutils
+ gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+ Please install GNU fileutils \
+))
+
define Require/working-gcc
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -