aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 10:42:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 10:42:32 +0000
commit48686e826659c65c165ad29e9421f45f375d13fc (patch)
tree04a736b5790374dfeafcac2cdd26a9ef6cbc22f6 /include/prereq-build.mk
parent011aaeec01e870c9b1248194cd4522d51174d1de (diff)
downloadmaster-187ad058-48686e826659c65c165ad29e9421f45f375d13fc.tar.gz
master-187ad058-48686e826659c65c165ad29e9421f45f375d13fc.tar.bz2
master-187ad058-48686e826659c65c165ad29e9421f45f375d13fc.zip
Support LibreSSL as provider of openssl
The build scripts check for openssl by grepping the string "OpenSSL" in the output of openssl version command. LibreSSL fails this test as it outputs something like "LibreSSL 2.2.4". This patch fix the prereq-bulid.mk file so that it accepts LibreSSL as openssl provider as well. Signed-off-by: Marek Behun <kabel@blackhole.sk> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48267 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 77fa991b04..bcb2103047 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -161,7 +161,7 @@ $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
- openssl version | grep OpenSSL))
+ openssl version | grep '\(OpenSSL\|LibreSSL\)'))
# Install ldconfig stub