aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-23 02:56:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-23 02:56:30 +0000
commit41dc41e96e920be2cf13caaa353e3a69ffb74429 (patch)
treebb23ae4069e0a9ec02c137ad501e413a64309497 /include/prereq-build.mk
parente1ec900c8ea859c65490bcd06c3931a1ffcd4c5a (diff)
downloadmaster-187ad058-41dc41e96e920be2cf13caaa353e3a69ffb74429.tar.gz
master-187ad058-41dc41e96e920be2cf13caaa353e3a69ffb74429.tar.bz2
master-187ad058-41dc41e96e920be2cf13caaa353e3a69ffb74429.zip
add better working-g++ check (patch from #2017)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8118 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6311e601ba..c31020c321 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
define Require/working-g++
echo 'int main(int argc, char **argv) { return 0; }' | \
- g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+ g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+ $(TMP_DIR)/a.out
endef
$(eval $(call Require,working-g++, \