aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-02 10:57:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-02 10:57:14 +0000
commit3d3798ce2ccc005c3884214e7d221d335fb64034 (patch)
tree15b8710782e0c856603655a8141ac75e43b90511 /include/prereq-build.mk
parentb85d4c1587e4af10c686d7663011217e7341ab83 (diff)
downloadmaster-187ad058-3d3798ce2ccc005c3884214e7d221d335fb64034.tar.gz
master-187ad058-3d3798ce2ccc005c3884214e7d221d335fb64034.tar.bz2
master-187ad058-3d3798ce2ccc005c3884214e7d221d335fb64034.zip
add prereq check for extended getopt (#3944)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12491 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index fbe7d69f44..d6d2d73a63 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -134,3 +134,11 @@ endef
$(eval $(call Require,gnu-find, \
Please install GNU find \
))
+
+define Require/getopt-extended
+ getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+ Please install an extended getopt version that supports --long \
+))