aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-20 09:17:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-20 09:17:56 +0000
commit1ce52220543aae7830dc05ed1979916c7df7fa30 (patch)
tree5348307a4722f34cb5d752aab338d14fc60729cb /include/prereq-build.mk
parent669f224beb19192e2c80b144af1287c455bcb0cf (diff)
downloadmaster-187ad058-1ce52220543aae7830dc05ed1979916c7df7fa30.tar.gz
master-187ad058-1ce52220543aae7830dc05ed1979916c7df7fa30.tar.bz2
master-187ad058-1ce52220543aae7830dc05ed1979916c7df7fa30.zip
prereq-build: replace the openssl command check with a check for headers
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42995 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index cb23f85647..4a87c9211a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,8 +168,13 @@ $(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))
-$(eval $(call RequireCommand,openssl, \
- Please install openssl. \
+define Require/openssl
+ echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
+ gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
+endef
+
+$(eval $(call Require,openssl, \
+ Please install openssl (with development headers) \
))
define Require/gnu-find