aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-30 17:14:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-30 17:14:47 +0000
commit01b743384d1e96b74dd5b50605875ed88a4f8c87 (patch)
treeac720d21a5579c7185f7d666ea70154aa5c19335 /include/prereq-build.mk
parenta30ef3735f0384af2cc891625ebfdb7df77cb6af (diff)
downloadmaster-187ad058-01b743384d1e96b74dd5b50605875ed88a4f8c87.tar.gz
master-187ad058-01b743384d1e96b74dd5b50605875ed88a4f8c87.tar.bz2
master-187ad058-01b743384d1e96b74dd5b50605875ed88a4f8c87.zip
prereq-build: check for "bc" (#13767)
bc is required by the kernel to compute timeconsts files, add bc to the list of prereq to build OpenWrt. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37108 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 59ea7ef9a7..dadce81ad5 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -183,3 +183,7 @@ endef
$(eval $(call Require,getopt-extended, \
Please install an extended getopt version that supports --long \
))
+
+$(eval $(call RequireCommand,bc, \
+ Please install bc. \
+))