aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-12 11:09:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-12 11:09:05 +0000
commitb2e87f2906d23b27b15f002ab41e7650dec6962f (patch)
tree025d39afe858e1a8d8ae6c11cbab3ae31f9effd2 /include/package.mk
parent916382168371178c24cd4b9550b200f940496131 (diff)
downloadmaster-187ad058-b2e87f2906d23b27b15f002ab41e7650dec6962f.tar.gz
master-187ad058-b2e87f2906d23b27b15f002ab41e7650dec6962f.tar.bz2
master-187ad058-b2e87f2906d23b27b15f002ab41e7650dec6962f.zip
Fix the annoying base-files autorebuild bug.
When checking file mtimes in directories, timestamp.pl was following symlinks. This broke on base-files, because there are symlinks to /tmp and to /proc/mounts in the build directory. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6084 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 1b69cf25d6..ffab228aae 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -21,7 +21,7 @@ define Build/DefaultTargets
ifeq ($(DUMP),)
ifeq ($(CONFIG_AUTOREBUILD),y)
_INFO:=
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(PKG_FILE_DEPEND)),$(PKG_BUILD_DIR))
_INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
$(PKG_BUILD_DIR)/.prepared: package-clean
endif