aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:00 +0000
commit8ef94e67c30efa29aa74956a981a9aee4a75dac9 (patch)
tree47ef56c3c0492847bd6649dffc990c6644e5631f /include/package.mk
parent5dd04b43f544fa6ff626102640f598d91331aa90 (diff)
downloadmaster-187ad058-8ef94e67c30efa29aa74956a981a9aee4a75dac9.tar.gz
master-187ad058-8ef94e67c30efa29aa74956a981a9aee4a75dac9.tar.bz2
master-187ad058-8ef94e67c30efa29aa74956a981a9aee4a75dac9.zip
build: add a variable for injecting config variable dependencies for the .prepared stamp
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32368 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 30dd3ec828..e955c207ae 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -31,7 +31,7 @@ ifneq ($(PREV_STAMP_PREPARED),)
STAMP_PREPARED:=$(PREV_STAMP_PREPARED)
CONFIG_AUTOREBUILD:=
else
- STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
+ STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),))$(call confvar,$(PKG_PREPARED_DEPENDS)))
endif
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured$(if $(DUMP),,_$(call confvar,$(PKG_CONFIG_DEPENDS)))
STAMP_CONFIGURED_WILDCARD=$(patsubst %_$(call confvar,$(PKG_CONFIG_DEPENDS)),%_*,$(STAMP_CONFIGURED))