aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-25 10:34:06 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-25 10:34:06 +0000
commit3f157df8b9412dc9efe8c51226b40632c2e143b9 (patch)
tree579672b7c8bf3fe6f5a51d3dc3aa209e64fa9f65 /include/package.mk
parent88982aa06cc879e948296a42a11cc77d80e75f56 (diff)
downloadmaster-187ad058-3f157df8b9412dc9efe8c51226b40632c2e143b9.tar.gz
master-187ad058-3f157df8b9412dc9efe8c51226b40632c2e143b9.tar.bz2
master-187ad058-3f157df8b9412dc9efe8c51226b40632c2e143b9.zip
[include] use autoreconf hook instead of manual call
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index abffa0c64c..64973b0510 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -76,6 +76,9 @@ ifeq ($(CONFIG_$(PKG_NAME)_USE_CUSTOM_SOURCE_DIR),y)
PKG_SOURCE_URL:=
# add hook to install a link to customer source path of dedicated package
Hooks/Prepare/Pre += prepare_custom_source_directory
+ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
+ Hooks/Configure/Pre += autoreconf_target
+endif
# define empty default action
define Build/Prepare/Default
@: