aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-18 00:37:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-18 00:37:18 +0000
commit39abef72dc1ac0470b0367ae2aa56947aa67a340 (patch)
treee43f2bb27ae99c7073fdaed66cc00538516f2ea8 /include/package.mk
parentc8a91544bb6d67ffc74599af7e22922b6b94313c (diff)
downloadmaster-187ad058-39abef72dc1ac0470b0367ae2aa56947aa67a340.tar.gz
master-187ad058-39abef72dc1ac0470b0367ae2aa56947aa67a340.tar.bz2
master-187ad058-39abef72dc1ac0470b0367ae2aa56947aa67a340.zip
build: explicitly unexport CONFIG_SITE
On systems with CONFIG_SITE in the environment (e.g. OpenSUSE) make will export the CONFIG_SITE set in include/package.mk by default. This will cause host builds to get the target site configuration, leading to all kinds of weirdness (wrong pointer size, wrong endianess). Fix this by explicitly unexporting CONFIG_SITE. The explicit export for the target builds overrides the unexport, so the target builds will still correctly get the site config. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44019 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 2c34a5850c..8208e36cfc 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -131,7 +131,7 @@ CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
CUR_MAKEFILE:=$(filter-out Makefile,$(firstword $(MAKEFILE_LIST)))
SUBMAKE:=$(NO_TRACE_MAKE) $(if $(CUR_MAKEFILE),-f $(CUR_MAKEFILE))
PKG_CONFIG_PATH=$(STAGING_DIR)/usr/lib/pkgconfig:$(STAGING_DIR)/usr/share/pkgconfig
-unexport QUIET
+unexport QUIET CONFIG_SITE
ifeq ($(DUMP)$(filter prereq clean refresh update,$(MAKECMDGOALS)),)
ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)