aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-26 18:04:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-26 18:04:16 +0000
commit2dcaf582db6426bfaf995f9427cdefce26a3e634 (patch)
tree31ef8fcba317d3a164170e1106aa21d773d70777 /include/package.mk
parent3efafd390f1b7518e38cb91cca0b3d991ce7e00e (diff)
downloadmaster-187ad058-2dcaf582db6426bfaf995f9427cdefce26a3e634.tar.gz
master-187ad058-2dcaf582db6426bfaf995f9427cdefce26a3e634.tar.bz2
master-187ad058-2dcaf582db6426bfaf995f9427cdefce26a3e634.zip
Small bugfix for dependency handling - mostly for base-files and symlinks
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7058 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index c31b955885..fe6a7617c8 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -26,8 +26,8 @@ export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
ifneq ($(CONFIG_AUTOREBUILD),)
define Build/Autoclean
$(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
- $(call rdep,${CURDIR},$(STAMP_PREPARED),$(TMP_DIR)/.packagedir_$(shell echo "${CURDIR}" | md5s))
- $(call rdep,$(PKG_BUILD_DIR) $(PKG_FILE_DEPEND),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+ $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(TMP_DIR)/.packagedir_$(shell echo "${CURDIR}" | md5s))
+ $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
endef
endif