aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-21 23:02:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-21 23:02:06 +0000
commit17057a805e54103d740d3499c013d5a0b0b4c1ea (patch)
treef17e010692719e02dbb74e33b3b71e12285cec25 /include/package.mk
parente29c4698e94365bc47981ccc057076425f74ab8d (diff)
downloadmaster-187ad058-17057a805e54103d740d3499c013d5a0b0b4c1ea.tar.gz
master-187ad058-17057a805e54103d740d3499c013d5a0b0b4c1ea.tar.bz2
master-187ad058-17057a805e54103d740d3499c013d5a0b0b4c1ea.zip
add support for md5sum checks for mirrored tarballs of packages with version control source urls
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26260 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index 2ebd66d119..1c2c179cda 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -79,6 +79,7 @@ define Download/default
SUBDIR:=$(PKG_SOURCE_SUBDIR)
PROTO:=$(PKG_SOURCE_PROTO)
$(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))
+ $(if $(PKG_MIRROR_MD5SUM),MIRROR_MD5SUM:=$(PKG_MIRROR_MD5SUM))
VERSION:=$(PKG_SOURCE_VERSION)
MD5SUM:=$(PKG_MD5SUM)
endef