aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-29 10:31:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-29 10:31:45 +0000
commit08f8c7edafc9a5357173e45803e5013f41492eca (patch)
tree69bd903da5b0c2a82dd54e4ba4e36b686cb33cf6 /include/package.mk
parentb8b35e19baf20e7859c8a2b165d8b8cffdd2f14e (diff)
downloadmaster-187ad058-08f8c7edafc9a5357173e45803e5013f41492eca.tar.gz
master-187ad058-08f8c7edafc9a5357173e45803e5013f41492eca.tar.bz2
master-187ad058-08f8c7edafc9a5357173e45803e5013f41492eca.zip
build: clean up stale files from a previous build when installing a package build to the staging dir
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36755 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index 99d2dd270e..a4f353be95 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -171,6 +171,11 @@ define Build/DefaultTargets
$(foreach hook,$(Hooks/InstallDev/Post),\
$(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
)
+ if [ -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) ]; then \
+ $(SCRIPT_DIR)/clean-package.sh \
+ "$(STAGING_DIR)/packages/$(STAGING_FILES_LIST)" \
+ "$(STAGING_DIR)"; \
+ fi
if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
(cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(TMP_DIR)/stage-$(PKG_NAME).files); \
$(call locked, \