aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-seccomp.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-26 10:57:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-26 10:57:56 +0000
commit3d898d18875741016ed7cb372773a2780308f602 (patch)
tree9680600184b2bf59767c87e01d94ceff7df087e8 /include/package-seccomp.mk
parent15527f7f5abe6c739de6195d3d450d1dc6c40f65 (diff)
downloadmaster-187ad058-3d898d18875741016ed7cb372773a2780308f602.tar.gz
master-187ad058-3d898d18875741016ed7cb372773a2780308f602.tar.bz2
master-187ad058-3d898d18875741016ed7cb372773a2780308f602.zip
include: add a seccomp filter install wrapper
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45006 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-seccomp.mk')
-rw-r--r--include/package-seccomp.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/package-seccomp.mk b/include/package-seccomp.mk
new file mode 100644
index 0000000000..fa49617d41
--- /dev/null
+++ b/include/package-seccomp.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+PKG_CONFIG_DEPENDS+= CONFIG_KERNEL_SECCOMP
+
+ifeq ($(CONFIG_KERNEL_SECCOMP),y)
+ define InstallSeccomp
+ $(INSTALL_DIR) $(1)/etc/seccomp
+ $(INSTALL_DATA) $(2) $(1)/etc/seccomp/
+ endef
+endif